Sicherheitslage
Sicherheitswarnung
Apache Struts: kritische Schwachstelle (CVSS 9,8)
Diese Lücke ist mit CVSS 9,8 von 10 bewertet und lässt sich übers Netz ohne Anmeldung ausnutzen. Auf der CISA-Liste aktiv angegriffener Lücken steht sie derzeit nicht – Updates sollten trotzdem zeitnah eingespielt werden.
Improper neutralization of special elements used in an expression language statement ('Expression Language Injection') vulnerability in Apache Struts. If the application is configured to use the legacy RESTful action mapper, a crafted request can inject an OGNL expression that may lead to remote code execution. Struts 7 is affected only when the OGNL allowlist is disabled; it is enabled by default. Applications using the default action mapper, the restful2 mapper, or the Struts REST plugin are not affected.
This issue affects Apache Struts: from 2.0.0 through 2.3.37, from 2.5.0 through 2.5.33, from 6.0.0 through 6.11.0, from 7.0.0 through 7.3.0.
Users are recommended to upgrade to version 6.12.0 or 7.4.0, which fixes the issue.
Kennung: CVE-2026-104711
Quelle: NVD (USA), gemeldet von Apache